Search code examples
javamethodsnaming-conventions

determining which verb to use for method names in Java


I understand that naming conventions are important for a number of reasons, most having to do with making your code more readable and easier to integrate into larger projects, etc. In Java, most conventions require that method names be in lowerCamelCase begin with a verb.

My question is: how do I choose the verb to begin the method name?

To make this question less vague, I'm often in the situation where my first choice for a method name is a noun describing the output. In these cases, I'm usually torn between appending generic verbs such as get, generate, calculate, etc in font of the noun to conform to the verb rule. Are there general guidelines for when to use which?

Here's an example. I have a method that takes double[] array and an int k and returns double[] newArray which is the length k moving average of array, i.e. newArray[i] = (array[i-k+1]+...+array[i])/k with some fudging to make newArray the same length as array. My inclination is to call this method movingAverage since that's what it returns, but that's out since it doesn't begin with a verb. Should I call this method getMovingAverage or generateMovingAverage or calculateMovingAverage or does it not really matter?


Solution

  • I usually ask myself:

    What is this method doing?

    The answer dictates what the method should be called. It is completely independent of the programmer, of course.

    Note: If you can't succinctly describe what the method is doing, it's probably doing too much and should be split up.

    Choosing your method's verb:

    • Performing calculation(s): calculate
    • Retrieving data: get or retrieve
    • Mutating data: set or change
    • Deleting data: delete or remove
    • Converting: convert
    • Initiating an action: start or initiate
    • Stopping an action: stop or cancel

    Now, not all methods begin with a verb; but they really don't need to. If you read:

    ... myString.length();
    

    or

    ... myArray.size();
    

    you know exactly what is going on - no verb required. This is true for many class methods higher up in the Java hierarchy; Collections, Math, etc. As long as the name accurately communicates what the method does, it's fine.