javascriptnode.jsangulartypescriptpackage

Angular 11 not working with any version of ngx chess-board but worked fine with @angular/cdk: "^12.2.9",


I had angular ngx-chess-board working but now when I try to run it with angular 11, I get the version incompatible error. The ngx-chess-board supports version of cdk 10 or 13 but I am using 11. I have tried all versions of ngx-chess-board but cannot get a cannot get any version to work with my cdk version.

The Project worked fine with cdk version "@angular/cdk": "^12.2.9" but all other packages use angular 11 thus require angular cdk version 11. Is there any way I can fix this issue or satisfy both?

I get the following error:

  npm ERR! code ERESOLVE
   npm ERR! ERESOLVE unable to resolve dependency tree
   npm ERR! 
   npm ERR! While resolving: [email protected]
   npm ERR! Found: @angular/[email protected]
   npm ERR! node_modules/@angular/cdk
   npm ERR!   @angular/cdk@"^11.0.6" from the root project
   npm ERR! 
   npm ERR! Could not resolve dependency:
   npm ERR! peer @angular/cdk@"^10.2.5" from [email protected]
   npm ERR! node_modules/ngx-chess-board
   npm ERR!   ngx-chess-board@"2.1.18" from the root project
   npm ERR! 
   npm ERR! Fix the upstream dependency conflict, or retry
   npm ERR! this command with --force, or --legacy-peer-deps
   npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

my package.json is:

    {
  "name": "DineNGo",
  "version": "2.0.0",
  "browser": {
    "fs": false,
    "path": false,
    "os": false
  },
  "scripts": {
    "ng": "ng",
    "main": "server.js",
    "heroku-postbuild": "ng build --aot --configuration=${ENV}",
    "preinstall": "npm install -g @angular/cli @angular/compiler-cli --legacy-peer-deps",
    "start": "ng serve",
    "cypress:open": "cypress open",
    "cypress:run": "cypress run",
    "lint": "ng lint",
    "e2e": "ng e2e"
  },
  "private": true,
  "dependencies": {
    "@angular-devkit/build-angular": "^0.1102.19",
    "@angular/animations": "^11.0.6",
    "@angular/cdk": "^11.0.6",
    "@angular/cli": "^11.0.6",
    "@angular/common": "^11.0.6",
    "@angular/compiler": "^11.0.6",
    "@angular/compiler-cli": "^11.0.6",
    "@angular/core": "^11.0.6",
    "@angular/flex-layout": "^11.0.0-beta.33",
    "@angular/forms": "^11.0.6",
    "@angular/language-service": "^11.0.6",
    "@angular/localize": "^11.0.6",
    "@angular/material": "^11.0.6",
    "@angular/platform-browser": "^11.0.6",
    "@angular/platform-browser-dynamic": "^11.0.6",
    "@angular/router": "^11.0.6",
    "@ng-bootstrap/ng-bootstrap": "9.0.2",
    "@ngtools/webpack": "^11.0.0",
    "@ngx-translate/core": "13.0.0",
    "@ngx-translate/http-loader": "^4.0.0",
    "@types/chart.js": "^2.7.42",
    "@types/chartist": "^0.9.38",
    "@types/crypto-js": "^3.1.47",
    "@types/express": "^4.17.0",
    "@types/jasmine": "~2.8.6",
    "@types/jasminewd2": "~2.0.3",
    "@types/lodash": "4.14.135",
    "@types/node": "^11.15.54",
    "@types/socket.io": "^3.0.2",
    "@types/socket.io-client": "^3.0.0",
    "@types/uuid": "^8.3.0",
    "@types/w3c-web-usb": "^1.0.4",
    "@types/web-bluetooth": "0.0.4",
    "angular-bootstrap-md": "^11.1.0",
    "angular-cc-library": "^2.1.2",
    "angular-cli-ghpages": "^0.6.2",
    "angular-notifier": "^9.1.0",
    "angular-responsive-carousel": "^2.0.2",
    "angularx-qrcode": "^11.0.0",
    "apexcharts": "^3.25.0",
    "axios": "^1.3.6",
    "bcryptjs": "^2.4.3",
    "body-parser": "^1.18.3",
    "bootstrap": "^4.5.3",
    "chart.js": "^2.9.4",
    "chartist": "^0.11.4",
    "config": "^3.3.6",
    "core-js": "^2.5.4",
    "cors": "^2.8.5",
    "crypto": "^1.0.1",
    "crypto-js": "^3.3.0",
    "css-loader": "^2.1.0",
    "dotenv": "^6.1.0",
    "exec": "^0.2.1",
    "express": "^4.18.1",
    "express-jwt": "^7.7.5",
    "font-awesome": "^4.7.0",
    "fontawesome": "^5.6.3",
    "fs": "^0.0.1-security",
    "got": "^11.8.1",
    "hammerjs": "^2.0.8",
    "jsonwebtoken": "^8.2.2",
    "jwt-decode": "^3.1.2",
    "lodash": "4.17.11",
    "lz-string": "^1.5.0",
    "material-dashboard": "^2.1.0",
    "material-design-icons": "^3.0.1",
    "material-design-lite": "^1.3.0",
    "mdbootstrap": "^4.19.2",
    "mongodb": "^3.0.10",
    "mongoose": "^5.1.4",
    "ng-apexcharts": "1.5.12",
    "ng-chartist": "^4.1.0",
    "ng-multiselect-dropdown": "^0.2.14",
    "ng-socket-io": "^0.2.4",
    "ngx-autosize": "^1.8.4",
    "ngx-bootstrap": "^6.2.0",
    "ngx-chess-board": "2.1.18",
    "ngx-device-detector": "^2.0.0",
    "ngx-guided-tour": "^1.1.11",
    "ngx-swiper-wrapper": "^10.0.0",
    "openai": "^4.15.0",
    "path": "^0.12.7",
    "popper.js": "^1.15.0",
    "postcss": "^8.4.14",
    "protractor": "^7.0.0",
    "remote-pay-cloud": "4.1.1",
    "remote-pay-cloud-api": "4.0.4",
    "request": "^2.88.2",
    "request-promise": "^4.2.4",
    "resize-base64": "^1.0.12",
    "rootpath": "^0.1.2",
    "rxjs": "^6.5.2",
    "rxjs-compat": "^6.3.3",
    "socket.io": "^4.6.2",
    "socket.io-client": "^4.6.2",
    "time-ago-pipe": "^1.3.2",
    "ts-node": "6.0.0",
    "tslib": "^1.9.0",
    "typescript": "4.0.5",
    "uuid": "^3.3.2",
    "web-animations-js": "^2.3.2",
    "zone.js": "~0.10.3"
  },
  "devDependencies": {
    "@angular-devkit/core": "^11.0.0",
    "@angular-devkit/schematics": "^11.0.0",
    "codelyzer": "^6.0.2",
    "cypress": "^9.7.0",
    "cypress-cucumber-preprocessor": "^4.3.1",
    "cypress-multi-reporters": "^1.6.0",
    "eslint-plugin-cypress": "^2.10.3",
    "express-jwt": "^7.7.5",
    "jasmine-core": "~2.99.1",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "^6.4.0",
    "karma-chrome-launcher": "~2.2.0",
    "karma-coverage-istanbul-reporter": "~2.0.0",
    "karma-jasmine": "~1.1.1",
    "karma-jasmine-html-reporter": "^0.2.2",
    "ng2-charts-schematics": "^0.1.7",
    "protractor": "^7.0.0",
    "swiper": "^6.8.4",
    "tslint": "~6.1.3"
  },
  "engines": {
    "node": "16.16.0",
    "npm": "8.11.0"
  }
}

Solution

  • Looking at the error you are having a dependency conflict with your ngx-chess-board version on the @angular/cdk package version:

     npm ERR! While resolving: [email protected]
       npm ERR! Found: @angular/[email protected]  <<< HERE
       ...
       npm ERR! peer @angular/cdk@"^10.2.5" <<< HERE
       npm ERR! node_modules/ngx-chess-board
       npm ERR!   ngx-chess-board@"2.1.18" from the root project
    

    Looking at the ngx-chess-board repo, version 2.1.8, we can see it is compatible with @angular/cdk@"^10.2.5 (angular 10.x)

    It looks like ngx-chess-board does not have a version compatible with angular 11.x.. (at least not on their repo's tags)

    I would recommend you upgrade your app to angular 13.x so you can use the latest version of ngx-chess-board (v2.2.3 as of writing), as it is compatible with angular 13.x

    Alternatively you could use this commit from ngx-chess-board, as it seems to be compatible with angular 11.