macosxamppcomposer-phphomebrew

dyld[45923]: Library not loaded: /usr/local/opt/libavif/lib/libavif.15.dylib


dyld[45923]: Library not loaded: /usr/local/opt/libavif/lib/libavif.15.dylib
 Referenced from: <735019D8-AF6E-3CD1-9AD4-3BE47CB22D4F> /usr/local/Cellar/gd/2.3.3_5/lib/libgd.3.dylib
 Reason: tried: '/usr/local/opt/libavif/lib/libavif.15.dylib' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/usr/local/opt/libavif/lib/libavif.15.dylib' (no such file), '/usr/local/opt/libavif/lib/libavif.15.dylib' (no such file), '/usr/local/lib/libavif.15.dylib' (no such file), '/usr/lib/libavif.15.dylib' (no such file, not in dyld cache), '/usr/local/Cellar/libavif/1.0.1/lib/libavif.15.dylib' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/usr/local/Cellar/libavif/1.0.1/lib/libavif.15.dylib' (no such file), '/usr/local/Cellar/libavif/1.0.1/lib/libavif.15.dylib' (no such file), '/usr/local/lib/libavif.15.dylib' (no such file), '/usr/lib/libavif.15.dylib' (no such file, not in dyld cache)

I updated MacOS to Sonoma and I had problem with XAMPP. So, I reinstalled XAMPP. Now this error is showing. I can't use PHP and Composer.


Solution

  • I had the same issue after installing macOS Ventura.

    Try to reinstall gd:

    brew reinstall gd