visual-studio-codegccmingw

How to Update GCC to include C++20


This is likely a straightforward fix, but I need to upgrade my g++ compiler to include C++ 20 libraries such as <span> and <range> on Visual Studio Code but I am confused about how to do that.

From what I've looked up, to allow Visual Studio Code to compile with C++20 libraries, I need to run mingw-get update but I have no idea where I actually run that command to update the compiler for Visual Studio Code.


Solution

  • You need a recent version of GCC+MinGW-w64 that supports C++20. You can get it via MSYS2's package manager pacman, or if you don't need MSYS2 you can get a standalone version from https://winlibs.com/.