Why is the experimental name is_ready()
considered as an enhancement to std::future
and not ready()
which is more consistent with the STL coding style? Future already has a method called valid()
which also doesn't have the is_
prefix.
I suspect it's because of already existing enum constant std::future_status::ready
. So is_ready()
checks for the status ready
. Although they both are in different naming scopes, I assume authors wish to avoid name intersection.