Search code examples
sqlsql-server-2008sql-server-2008-r2utm

How to configure UTM to remotely access SQL Server2008 R2


I have installed SQL Server 2008 R2 on my server and Configure SQL server and Windows firewall installed on server.It works fine over the LAN. Now I am trying to access it over internet with the public ip of our server.We have installed UTM Fortigate firewall for security. Can any one tell me how could I configure UTM for global access of SQL server ??


Solution

  • You need to configure a VIP - Virtual IP, and a port mapping. The VIP needs to listen on your external interface, and re-direct the traffic to the internal server. Can be done in GUI, or via CLI:

    config firewall vip
        edit "sql_server"
        set extintf "<external_if>"
        set portforward enable
        set mappedip <ip_of_server>
        set extport <external_port_number_to_listen_on>
        set mappedport <internal_port_on_server>
        end
    end
    
    config firewall policy
    edit 0
        set srcintf "<external_if>"
        set dstintf "internal_if"
        set srcaddr "all"
        set dstaddr "sql_server"
        set action accept
        set schedule "always"
        set service "ALL"
    end
    end
    

    However, by doing this you are exposing your sql server to the whole internet. I would strongly suggest you also use authentication and possibly limit the src IP scope allowed to access the VIP.